de.skycoder42.qurlvalidator

A class that provides a QValidator to validate urls

version 1.1.0

To install:

❯ qpm install de.skycoder42.qurlvalidator

QUrlValidator

A class that provides a QValidator to validate urls

Can be used just like any QValidator. Can be limited to only accept specific schemes.

Installation

The package is providet as qpm package, de.skycoder42.qurlvalidator. To install:

  1. Install qpm (See GitHub - Installing, for windows see below)
  2. In your projects root directory, run qpm install de.skycoder42.qurlvalidator
  3. Include qpm to your project by adding include(vendor/vendor.pri) to your .pro file

Check their GitHub - Usage for App Developers to learn more about qpm.

Important for Windows users: QPM Version 0.10.0 (the one you can download on the website) is currently broken on windows! It's already fixed in master, but not released yet. Until a newer versions gets released, you can download the latest dev build from here:

Author

Skycoder

Info
View on Github

License: BSD_3_CLAUSE

Installs
Today 1
This week 2
This month 2
This year 7
Total 7
Dependencies

None.

Versions